Connecting the cloud only a part of my program is sent to my PC


#1

Hey,

In the last month I was confronted twice with the following problem.:
My browser (Firefox) was asked to connect to https://build.particle.io/build/5c0d3a341fbdb4731a0014e4
I log in with my credentials and the .ino file I asked for is displayed on my screen. No problems yet.
When I scroll trough that file, once I come to the line 98, I cannot go further anymore and on top of my browser a message is displayed in a yellow line “this page is slowering your browser, do you wish to wait or to exit”. Waiting doesn’t bring a solution. And finishing and restarting the browser and so on, doesn’t give a better situation.

I have the same problem on my laptop and on my desktop.
It gives me the impression the cloud-server is refusing to send the rest of the file to my PC.

On the other hand, the functionality of the cloud is still OK : I can still “compile” the program, (and, of course, I get the message Great work !) I also can flash the “unaccessible” program to my Photon with succes. So those functions are still working correctly.

The other .ino files from my library don’t give the same problems : they are still full accessible and I can edit them freely without problems.

My questions :

  1. how can I solve that problem so I can further edit that “blocked” program ?
  2. what is the best way to take a backup after each change I made to a program ?
    (for the moment, I make a copy on Word, Excel or Notepad.) I think there must be a more userfriendly way.
  3. Is it possible to ask a Photon to download the actual working program back to my PC.?
    (of course I can take it from the cloud, but as said, for unknown reasons the cloud doesn’t give the full text anymore)

On beforehand THANKS for your help.
Jacques V


#2

We cannot access your private project link.
If you want to share a project you can use SHARE THIS REVISION to create a publish link to a copy of your project.

I have also seen similar behaviour with some code, but could never find out what caused it. However, I don’t think it’s an issue with the Particle servers but rather the browser and something specific to to actual code.
I can scroll through other projects with hundreds of code lines but on some other project the scrolling breaks at the same line over and over :man_shrugging:

You can use the already mentioned SHARE THIS REVISION feature and store the links of each individual revision you want to keep, but the whole project and all shared revisions depend on the original project to exist in your account. Once you remove the original, all stored revisions will be discarded too.
The other option is this Web IDE feature


image

Not really, since the device only holds the binary and never really “sees” the source code.


#3

Hey,

THX for your answer.

You asked me to “Share this revision”. I was following the procedure and got a link copied on my desktop.
The link is : https://go.particle.io/shared_apps/5c594918b314d500050a4033

Can you access my .ino file with that information ? And if YES, is it possible for you to have the entire file downloaded and send it to me ? My emailadress is known, I think…

Thx also for the other information I found in your mail
wkr
Jaak.


#4

I could, but why?
You can download the entire project as ZIP file yourself the way I showed you as second option (Download app sources).

I’m using Chrome and can scroll through your entire code - tried with Firefox now too, and also no issue.

Also, have you tried opening your own shared link?
Does the scrolling also break at the same place with that copy?

However, I just let a auto-reformat run over your code have a try with this
https://go.particle.io/shared_apps/5c5c7aaaf87bba0005d357e6


#5

THX for your highly appreciated help.

As suggested I tried to access that file via CHROME (on my Raspberry 3b+) and everything was OK : the whole file was accessible. So my problem is solved.

As for your other suggestions, trying to open via Zip-file : I will try this in the next few days.
Idem for the last link you sent to me.

I’ll inform you about my experiences with those trials.
AGAIN : THANKS a LOT !!!
Jaak.


#6

Hey,

I’m coming back to you, earlier than expected. Just to give you more information.

As said before, my whole file was perfectly accessed by Chrome. So I copied that full file and via my Laptop (working in Firefox) I copied that information in a new .ino file in my web-page.
And, trying to work with that new file, I was again blocked after line 98.

After that, I deleted the original file in my web-page and made a new file with the same name. Also there I copied the full .ino information. And again I was blocked at line 98.

There must be an incompatibility with something around line 98 of my .ino-file and Firefox.

I think, for until now unknown reasons, I have to work further on this ino-program with Chrome.
(but all my other programs don’t give problems in Firefox)

Just for information,
wkr
Jaak


#7

What version Firefox and what OS are you running?
Does the Firefox developer console provide any clues why it gets stuck?
Have you tried that with my reformatted sources?


#8

Hey,
on my laptop (Vaio with i7) I have Win Pro version 1803 from 14/08/2018.
The version of Firefox is Firefox Quantum 65.0 (64 bits)
Once the program is blocked, I do not have other possibilities than closing Firefox : so I cannot have more information about what was happening during the Firefox session itself.

This morning I succeeded to open only one of the two copies of the original file that was blocking my PC. The second copy ( see the link) was again blocked line 98.
https://go.particle.io/shared_apps/5c5d422fecdfdd000568b2dd

As far as I experienced now, I don’t have those problems with Chrome.

Wkr
Jaak


#9

You can open the developer console before scrolling down.


#10

Hey,
I was opening the developer console before scrolling down. I think the information is sent to the share option.
After that I scrolled down. Firefox blocked. Not possible anymore to open the console. But as I pressed Ctrl/Shift/K the console opened after restarting Firefox. Maybe with the needed information.

I hope this informtion is usefull
WKR
Jaak