CLI V2.7 particle subscribe mine not logging

I upgraded several devices to CLI 2.7 this morning, and the private subscribe no longer works. One is ubuntu 18, one is ubuntu 16, one is the VS platform. I left one device alone, running 2.6, and it works. I rolled back one ubuntu 16 instance by copying the 2.6 binary (bin/particle and ~/.particle) and it then works. I used the CLI package to perform the upgrades. By “works”, I mean that data is logged to the console when using ‘particle subscribe mine’. The 2.7 CLI never returns the listening to v1/events
response. I have also tee’d the output to a text file, and it never receives data, so it doesn’t appear to be registering or recording.
Thanks.

What command have you used for the subscription?

particle subscribe mine

Is mine the event name?

When you run particle subscribe --help you can see what options to use.

Your command would subscribe to private events starting with mine

that command logs all of the private events from my devices. It’s in the reference sheet for CLI:
Special device name “mine” will subscribe to events from just your devices.

It worked previously from VS studio, and still works from CLI running 2.6. They are also logging from the device console (console.particle.io).

This might be (for previous versions), but have you tried tried without mine? Maybe things change quicker than the documentation :wink:

And have you tried particle subscribe --help to learn what the current version does?
Does it list a “special device name” mine?

For me it’s not listed so I don’t care what may have been true for other versions but may not be anymore :sunglasses:

It’s always surprising to see reports about something not working but when alternatives or (possible) solutions are presented the immediate reaction is not to actually try it out but to argue against its validity :confused:

nope, it may/should (does for me) still work, but now maybe differently.

1 Like

Thanks for responding. I wanted to know if anyone else was having this problem. Looks like it was supported in 2.6 and dropped in 2.7, although still used as a keyword in part of the code. I think it would’ve been nice to document it as deprecated, or alias it to the new syntax for a revision. I understand the code changes faster than the docs.

Sorry, edit:
Current syntax for similar function is to not pass any arguments (v 2.7.0):
:~$ particle subscribe

Edit No 2:
Actually “mine” is supposed to still work. It’s picked up in line 48 in subscribeCommand:

else if (device){
			const source = device === 'mine' ? 'my devices' : `device ${device}'s stream`;
			msg.push(`from ${source}`);

which emits the status message:
Subscribing to “mine” from my devices
which calls getEventStream in api-client.js with the deviceId
which prints the log message “listening to …” to the CLI console.
So, at least on my machine(s), it appears the eventStream isn’t being created properly.
I will troubleshoot more later.

Yes, but then I’d think you’ll need to actively state it as device name like this

particle subscribe --device mine

However, when you now have a device actually called mine the logic breaks (again) as it wouldn’t do what the --device option is supposed to do.