CLI command Particle Identify crashes my Macintosh


#1

I was going to give my Particle to a friend and wanted a copy of the id.
The device has firmware 0.6.1 and I am running Mac OS X 10.9.5
I put the device into Listen Mode (medium speed blue flashing).
When I type “particle identify” (without the quotes) at the terminal prompt it replies with
the correct id and a few seconds later my machine crashes with a kernel panic.
No other Mac applications are running at the time.
Other CLI commands seem to work properly. For example: “particle list” returns the
id that I want (as well as firmware variables and functions).

Suggestions most appreciated.

Thanks everyone.


Alan


#2

hmm, perhaps reinstall or update the cli?
npm update -g particle-cli


#3

Good idea. Tried it - no change.
:frowning:

(FYI - on my third crash so it is easily repeatable.)


#4

particle-cli relies on node.js, perhaps update/upgrade that first?

brew update
brew upgrade node
npm install -g npm

#5

What versions (npm, node, CLI) are you running?


#6

cli = 1.21.0
node = 6.10.0
npm = 3.10.10


#7

I see node.js is not the latest so I updated to 6.10.2
No change: “particle identify” still results in kernel panic crash.


#8

Try using something else like CoolTerm and send “i” and see if it crashes.

It sounds more like a driver issue to me. First time hearing this behavior on a mac.


#9

Tried CoolTerm.
“i” responds with the id.
“m” responds with the Mac address,
“v” with the version,
etc.
No crashes.

Does this point the finger at the USB driver?


#10

To set the WiFi creds, send “w”

But for the CLI crashes we might ping @jvanier


#11

I tried a number of single letter commands just out of curiosity since I couldn’t find instructions. All seemed to work.

Please, if someone is willing to contact the CLI authority regarding the crashing, I would appreciate it.


#12

Had a brilliant thought (which are becoming more and more elusive these days.)

Last year I was playing with cheap Arduino clones which use the CH340 series USB chips, and
of course, had to download the Chinese USB driver to match. So, just now I reinstalled the
FTDI drivers and (drumroll please)… Success. No more kernel panic.

I will attempt to mark this as Solved, but if not successful perhaps a kind reader will do so for me.

Thanks for the responses - especially the one that suggested a bad driver.