Can't connect to the Electron using the CLI Access Denied

In windows 10, trying to flash my Electron over the usb connection. The Device Manager sees the electron and reports “Electron (COM4)” under Ports.

In a Command window, when I try to flash the Electron, here’s what I get:

particle flash --serial firmware.bin
! PROTIP: Hold the SETUP button on your device until it blinks blue!
? Press ENTER when your device is blinking BLUE [I wait until it flash blue, then…]
Error writing firmware: Opening COM4: Access denied

Any ideas?

i usually use an admin terminal or as windows shows Command Prompt(Admin).

I ran the Command Window in Admin Mode, but I still get the same error…

in that case i would look at device manager and see if there are any cross marks/alarms/or other signs. i know that some manufacturers lock down ports for various what i consider to be bogus reasons. i’d also do a google search with the terms being the manufacturer & model of pc you have & USB port access denied perhaps there will be clues specific to your pc. the only time i have had that issue was on my laptop when i did not use an admin command prompt terminal.

Well, I did 2 things, and now I am able to flash over serial. First I changed PCs, then I also did ‘particle login’ before running the serial flashing. In the tutorial https://docs.particle.io/tutorials/developer-tools/cli/ they don’t mention needing to do particle login, so presumably the difference was the different PC…