Cannot Find Bootloader for 0.6.3


#1

I need to downgrade from 0.7.0 O/S release because I am seeing photons online or offline very frequently that have been rock solid for years. Have tried all the recommended fixes.
1.0 Make sure blocking of main loop never occurs. FIXED
2.0 Run the WiFi stack in it’s own System Thread
3.0 Various Antennas etc that i don’t want to mention…

What I can’t find is where the bootloader for O/S 0.6.3 has been compiled for Photon. Looks like almost all the other releases for the O/S version have bootloaders precompiled on Git.

I see that one way is to compile the bootloader locally but I don’t want to go through the pain of trying to get gcc compiler and all it’s dependancies resolved.

I need to get my devices all downgraded quickly so life will be as it was.

Any suggestions?

ChipMonk


#2

The bootloader for 0.6.x can be found here:

If you are downgrading from 0.7.0 to 0.6.3 you don’t need to manually downgrade the bootloader. The system parts of 0.6.3 contain a bootloader and will fix it automatically.

Note that you must use 0.6.3 or 0.5.5. Those are the only two versions that know how to automatically downgrade a 0.7.x and later boot loader.


#3

Hi Rickas7,

Thanks for the response. I only find bootloader 0.6.2 on this page is this what is used for 0.6.3 OS?

I got into this bind when I downgraded from 0.7.0. i flashed part-2 then after it completed part-3.

The device still shows 0.7.0 in the Web IDE. Put the photon into Listening mode and did a particle serial inspect command.
Here’s what I got

Platform: 6 - Photon
Modules
Bootloader module #0 - version 101, main location, 16384 bytes max size
Integrity: PASS
Address Range: PASS
Platform: PASS
Dependencies: PASS
System module #1 - version 207, main location, 262144 bytes max size
Integrity: PASS
Address Range: PASS
Platform: PASS
Dependencies: PASS
System module #2 - version 207, main location, 262144 bytes max size
Integrity: PASS
Address Range: PASS
Platform: PASS
Dependencies: PASS
System module #1 - version 207
Bootloader module #0 - version 101
User module #1 - version 4, main location, 131072 bytes max size

empty - factory location, 131072 bytes max size

I read bootloader “101” as 0.6.2-rc.2 using your link to the bootloader mapping table.

So what I am doing to make this way to difficult?

ChipMonk


#4

The bootloader is the same for all 0.6.2 - 0.6.4. This table is handy for determining that:

Did you downgrade your user firmware to one that does not target 0.7.0 first? If downgrading OTA, the required order is:

  • User firmware targeting 0.6.3 or earlier
  • 0.6.3 System Part 2
  • 0.6.3 System Part 1

#5

I must have not put the user firmware in the correct build.

Do I have to compile tinker in 0.6.3 and flash it via DFU ?

Chip Monk


#6

The Tinker built into the CLI is fine with 0.4.2 and later:

particle flash --usb tinker

#7

Okay,

Thanks for the command.

Just entered DFU and did a particle flash --usb tinker

Flash worked.

Now checking particle inspect I find …

Bootloader module #0 - version 101

So this is 0.6.2 Bootloader accrording to the table…

Should this read as “Bootloader module #0 - version 109” which would be 0.6.3 bootloader?

FYI Web IDE shows 0.7.0

Still don’t feel all is setup correctly.

Chip Monk


#8

I can’t tell what state your device is in now. Since you have USB access to it:

particle flash --usb tinker
particle flash --usb system-part1-0.6.3-photon.bin
particle flash --usb system-part2-0.6.3-photon.bin
particle flash --serial bootloader-0.6.2-photon.bin

Note the first three must be in DFU mode (blinking yellow) and the last one is in listening mode (blinking dark blue). Also note the bootloader is 0.6.2 even though the rest of the system firmware is 0.6.3.


#9

Hi Rickas7,
I have USB mode access and did the procedure you listed.

Now inspecting using particle serial in “Listening Mode” I get the expected
System module #1 - version 109

And in the Web IDE this device “Moab” is at 0.6.3 !

My oversight was to not be aware that 0.6.2 bootloader would work.

I spent a lot of time trying to compile the 0.6.3 firmware on my MAC.

Thanks for the help.

Hopefully this gets me back to a stable photons.

Chip Monk


#10

Hi Rickas7,

Your help has my local particles rocking and rolling again!

I have not detected a single offline/online event in almost 12 hours of monitoring.

Thank you for the help getting to make the downgrade to 0.6.3 work!

ChipMonk