Build errors after trying to install local compile (using docker) [SOLVED]

Hello all, for some reason I decided that I wanted to be able to compile locally on my Windows machine. Unfortunately, the install failed miserably, and for a parting gift, I now can’t even compile using the cloud in dev. I’ve tried completely uninstalling everything, and then installing just dev and CLI, with no success in dev. However, compilation using the CLI is working.

For added detail, the error I get is …

Anybody with any help would be tremendously appreciated.

Help? Anyone?

First, there might be other reasons that cause this problem (e.g. multiple files containing setup() or loop() in scope for Dev).
Make sure (not just assume) that’s definetly not the case.
Try a completely new minimal project in a completely different location.
Post a screenshot of the full Dev window (status bar, side bar, menue, …)

If all not helps, you might have to uninstall Dev again and manually remove any directories on your drive that belong(ed) to it.
Also scan the registry for Atom and Dev and remove any traces there (with care).
Then restart your machine before trying to reinstall.

1 Like

Manually removing the directories and playing about in the registry did the trick! Thanks dude.