Bricked? main LED blank. corner Led solid blue? [SOLVED]

My core wouldn’t connect to my wifi (flashing blue) so I attempted the factory reset and now the main LED remains off. Only the corner blue LED is on.
Any suggestions?

Hi @Brungle,

Worry not! Keep trying factory reset, it can be hard to get it the first try, here’s a video: (dfu mode + keep holding mode == factory reset)


Thanks David but its just not working. Pressing and holding both buttons doesn’t do anything.

Hi @Brungle,

Did you watch the video?

Press both buttons, let go of the “RESET” button, and keep holding the mode button. Keep holding while it flashes yellow, and don’t let go until it flashes white! I’ve had my core in the same state at least twice today while testing, unless your core never worked to begin with, it’ll probably fix it.

If it doesn’t start flashing yellow after a few seconds, you’re holding down the wrong button! :slight_smile:


Thanks but the main LED does not come on at all no matter how long I hold both buttons.

I’d had the core working recently but kept getting flashing cyan so thought I’d do a factory reset and start again. I’d already reset it it recently withiut issues but this time it looks like its somehow locked up.

Hi Brungle… I had the same issue. But a Factory reset solved it… As Dave said

  • Hold the mode and reset together.
  • Let go of the reset and keep holding the mode button
  • The LED will flash yellow… Keep holding
  • The led will flash white
  • Let go of the mode button
  • Set the network up and let it restore.

Apologies if you’ve done this all before… It was letting go of the reset button that stumped me the first few times.


You guys were right! Its working fine now doh!! Many thanks

1 Like

Hi @Brungle,

Awesome! Glad you’re back up and running. :smile:


1 Like

I had this issue while trying to test out another bug issue.

Did a dump of the content from the External Flash. Is the SPI Flash content useful for us to understand stuff better?

@kennethlimcp Learning is always good! Here’s what’s going on on the external flash:

What I meant was I actually used DFU to dump the external flash from the core when it became ‘bricked’.

How can we use this content to figure out what happened that caused the issue? :slight_smile:

If you do a binary/text compare on the extracted BIN vs. the BIN you supposedly programmed, you could see if there was an error in programming. If the BINs are not different, then it was mostly likely a problem in your code or the way it compiled. What memory range did you extract via DFU?

I did the 0x08005000:leave. Sadly I didn’t dump the content when It worked fine.

The program works but the OTA somehow had a bad write or something. Was trying to verify it was the case with the dump

Anyone in future with this problem and don’t mind using dfu-util, can you try the following:

  1. Put your code into DFU mode (Press and hold both buttons, release the reset button till it blinks yellow and release mode button)

  2. Run the following commands

dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -U corrupt_firmware.bin
dfu-util -d 1d50:607f -a 1 -s 0x60000:0x80000 -U corrupt_ota_firmware.bin

  1. Factory reset your core

  2. Download your original code WITHOUT any modifications. If the flash is successful, Do DFU again

If the next download caused the same issue again (bad for you but good for catching the bug) please copy the code and share!

  1. Run the following commands

dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -U working_firmware.bin
dfu-util -d 1d50:607f -a 1 -s 0x60000:0x80000 -U working_ota_firmware.bin

  1. Show us your code and the 4 firmware files

Hopefully it’s a corrupted write that is observed and can be proven before the next step can be taken to catch this bug :blush: