Brand new photon just blinks an endless loop?

I have been digging for a couple of hours and cannot find anything that talks about or anything that fixes this issue.

My brand new (literally right out of the box - still attached to the foam shipping backing) Photon blinks: Purple, Yellow, Green, White for 2 seconds each and then two quick white and then repeats forever. I have left it for over an hour and it is the same. (I have a second one that worked perfectly right out of the box)

No button presses change this behavior - DFU, Reset, Safe Mode, nothing I press or change makes any difference. (USB Cables, different PC ports, etc…)

Has anyone seen anything similar and/or have any ideas?

@charrold303 I would help if you told if you have much experience with the Photon? Since this is your first post, I’m assuming that this is your first Photon (but I might of course be wrong). Right out of the box, all new Photon’s will blink Blue when powered up. I presume you’ve looked through this list of LED codes?

If you used the app to give the Photon wifi credentials, but it’s having problems connecting through your network, you’ll see this pattern. Could you try to connect it to another network? To enter Setup mode, hold the Setup button pressed down until it starts to blink blue.

@jenschr Sorry - thanks for that, yes Brand new to Photon itself, but not to similar platforms (arduino/Rpi) for IoT

So when I say that the aforementioned pattern of blinking LEDs is all it does, I literally mean, that’s it. From the very first time I plugged it in, no matter what button or combinations of buttons I press, it comes back to this pattern every time all the time (including after being unplugged, cable swapped, outlet swapped, computer swapped, and everything else I could think of swapped multiple times):

No blue blinks or magenta, or anything else, just Purple (well red and blue at the same time really, not purple exactly) for 2 seconds, Yellow for two seconds, Green for two seconds, White for 2 seconds and then two quick white and then repeats for as long as it has been plugged in.

I checked the LED codes doc and there isn’t even one in there for this pattern. It kind of almost looked like the blink pattern for DFU, but it isn’t and isn’t in DFU mode as evidenced by the fact that I cannot connect to it and the LED pattern is not the same anyway. (I tried my other one for comparison, and it worked fine)

I cannot get it to do anything other than blink like this so I cannot give it credentials or anything else so it has nothing to do with the wifi connection or credentials. Also, to be super clear about this:

pressing any of the buttons, for any length of time, in every pattern described in the docs and one’s I just tried for the hell of it, only restarts the blinking pattern as described in the issue. I cannot enter safe, listen, DFU, or any other modes.

I’ve only experienced a single bricked Photon and that one just blinks red. This is very odd.

So holding down Setup while pressing reset and then keeping Setup pressed for (up to) 10 seconds does not force it into DFU mode?

Nope - right back to the same blinks.

I have tried holding it down for quite some time as well (much more than 10 seconds) with no success

That foam is conductive (if I’m not mistaken), so you might want to take it out of that :sweat_smile:

1 Like

I checked - it’s not, but I had that thought for a brief horrifying second!

Also, after letting it sit for a very long time - over an hour - it stopped blinking altogether and then did nothing. Hit reset, and back to the same blinking pattern…

If it’s the black antistatic foam it in deed has conductive properties - how have you checked?
Anyway remove it from the device.

The color patern is in deed odd. Can you post a video?
And if you can manage to enter DFU Mode, you may need most recent CLI and execute

particle update

This pattern would fit to a stuck MODE/SETUP button.
Can you measure the voltage between GND and the solder pad 26 underneath the Photon?

It should read about 3.3V, if it doesn’t you may need to open a support ticket to get a replacement.

I stuck two ends of a multi-meter in it and it was negligible (I removed it anyway). Since I got this one from Amazon on a lightning deal, I just replaced it through them. No hassle.

Thanks for all the ideas, but I didn’t really want to spend a million hours troubleshooting - I have stuff to get built!

So does this mean your device is back to life again?

I returned it for a new one (and two more) so I have 4 running now.

1 Like