Boron only attaches to cellular when connected over USB

Hi, odd issue here. I’ve got a Boron LTE setup using a third-party SIM that works great when it’s connected over USB to my laptop. Light starts out blue flashing, then green flashing, then blue flashing, then happy breathing blue. However, when I change the Boron to powered from an adapter over USB or directly from a 5V source, it remains stuck at the initial flashing blue stage and never goes green (connecting to cellular, etc.). Further, if I power on the device externally, leave it stuck at this stage for a while, and then come back and plug it into my laptop, it will soon start flashing green and boot properly. This makes me think it’s waiting for some USB event to continue booting, but I can’t think of what that would be.

Has anyone ever seen something like this before? I can’t find any reference to a similar issue online. I’m running firmware v1.4.4 and the problem persists even after flashing my board back to the Tinker binary.

It would be helpful if you posted your code here. And, can you be more precise about the colors and the flash patterns of the LED? You say flashing and breathing blue, but I suspect you mean cyan. Flashing cyan and flashing blue mean two completely different things.

Also, and perhaps more to the point, if you can power the Boron with one power supply and it works, but it doesn’t work with another, I would suspect that second power supply is not providing adequate power. Not enough current, noisy signal, improper voltage, or something else. What is the external power supply you’re using?

Yes, sorry, it remains at the initial blue flash and does not go through to flashing and breathing cyan. The code I have it currently running is the Tinker sketch (particle flash --usb tinker). I will add that I have been flashing code in DFU mode during my development using the boron source (clone the source, use branch release/v1.4.4, edit application.cpp, build for boron and flash by running “make PLATFORM=boron program-dfu”), though like I said, the current running firmware is just the tinker sketch.

I was using a bench supply (30V/3A) that should have more than enough capability to power the device. I also tried a cheap USB charger to the same non-working effect. The boron will only advance to the flashing green stage (and on to slow flash cyan, fast flash cyan, breathing cyan) from the initial flashing blue stage when connected to my laptop. It stays flashing blue on any other power source.

Which of these are you seeing and in what sequence?

Flashing blue indicates listening mode, which when entered on power up means device setup has not been completed. I personally have never seen a Boron flash blue, then flash and breathe cyan (the latter meaning it’s connected).

EDIT: I overlooked the fact that you are using a third party SIM. I have had mixed results when trying to use anything other than the Particle SIM. It can work, but requires a lot of extra work in my experience. Behavior of the Boron with a third party SIM is not fully documented.

1 Like

Interesting. It would appear that it indeed is starting in Listening mode, but it also is definitely running the code that I am flashing. Maybe I need to do a manual setup complete mark? (

Yes, I would do that. I do it myself on my own devices since I don’t go through the normal setup process on new Borons (I set them up manually).

1 Like

That was it! Set the bit using dfu-util and then it immediately worked from any power source. Still, I wonder how I got into the situation I had before. It must have liked the particle client running on my machine, and that somehow let it transition out of Listening Mode? Glad I got it sorted out though, thank you for your help @picsil