Boron LTE Hologram SIM issue

boron
Tags: #<Tag:0x00007fe225eb7f08>

#1

I am using the hologram setup firmware noted in this topic

But this is as far as I am getting in the cloud debugger

starting tests...
turning cellular on...
0000015001 [system.nm] INFO: State changed: DISABLED -> IFACE_DOWN
0000020170 [hal] INFO: Using external Nano SIM card
0000020237 [gsm0710muxer] INFO: Starting GSM07.10 muxer
0000020239 [gsm0710muxer] INFO: Openning mux channel 0
0000020240 [gsm0710muxer] INFO: GSM07.10 muxer thread started
deviceID=e00fce68c94fc9d915ac4df4
0000020291 [gsm0710muxer] INFO: Resuming channel 0
0000020292 [gsm0710muxer] INFO: Openning mux channel 1
0000020392 [gsm0710muxer] INFO: Resuming channel 1
0000020393 [gsm0710muxer] INFO: Resuming channel 1
manufacturer=u-blox
model=SARA-R410M-02B
firmware version=L0.0.00.00.05.06 [Feb 03 2018 13:00:41]
ordering code=SARA-R410M-02B
IMEI=352753090643386
IMSI=u-blox
ICCID=<removed>
0000020796 [app] INFO: enabling trace logging
0000020797 [ncp.at] TRACE: > AT+CGDCONT?
0000020845 [ncp.at] TRACE: < +CGDCONT: 1,"IP","hologram","0.0.0.0",0,0,0,0
0000020846 [ncp.at] TRACE: < OK
0000020847 [ncp.at] TRACE: > AT+CSQ
0000020895 [ncp.at] TRACE: < +CSQ: 99,99
0000020896 [ncp.at] TRACE: < OK
attempting to connect to the cellular network...



#2

Is this a brand new, fresh SIM card? People in that thread noted issues with that.

Also, what happens after those cloud debugger commands? Is the device resetting, does it hang, or are there more logs? Usually there would be more logs after that, and things should keep happening.


#3

Im not sure what I did that finally worked. I flashed this boron over and over with system firmware, cellular config, tinker, cloud debugger…I may have just been impatient and didnt let the cellular config firmware run its full course.
Anyway I finally got the Hologram SIM working and the Boron is breathing cyan, however it wont do OTA flashing so I am trying to troubleshoot that. Perhaps a keep-alive issue?


#4

Yep, definitely could be a keep alive issue. In theory the previous bugs should be fixed in recent firmware, so you should be able to just set it once.

Particle.keepAlive(30) to make sure it works. Keep in mind you will need to also set the same keep alive on other nodes on your mesh network if applicable.


#5

+1 on the keepAlive. Setting this allowed me to keep my connection to the Particle cloud using Hologram.


#6

Only drag with keepAlive(30) is that it runs about 10mb of overhead per month…
I really wish Particle supported verizon out da box


#7

Keep in mind that your actual keepAlive time you need may vary, so test as needed. It may be different on LTE than 3G, I’m not sure.

But more importantly, depending on your application you may not actually need to be connected to the Particle Cloud 100% of the time. As long as you connect at least once in a while long enough to receive an OTA update (and to potentially refresh your time clock), you don’t “need” to be connected to the Particle Cloud. There’s a tradeoff between the data required to send the small keepAlive vs the larger data to perform a reconnection handshake.

I and others are happy to give more suggestions on saving data if you want to talk through your application more!