Atom now uses ES6 Promises instead of Q. Call promise.then instead of promise.done

I’ve tried to upgrade Atom 1.18.0 to 1.19.0. Unfortunately the automatic update didn’t work. So I downloaded the latest Atom 1.19.0 from particle website and installed it on my Mac OSX 10.12.6.

Since I did the upgrade, I get the following error message:

Atom 1.19.0 says that there are no available update. I’ve tried to google this error to no avail. Any hint how to solve this issue?

Since the upgrade I’ve a bunch of errors when compiling codes that did correctly compile on 1.18.0. And I’m wondering if it is not linked to the above message.

I am having the same problem. Did you get to solve it?


I solved it updating the target firmware through the console.
1.Install the Particle CLI.
2. Set the photon to DFU Mode. (yellow blinking)
3. from the prompt comand : particle flash --usb tinker
4. Set the photon to listening mode (blue blinking).
5. Setup again the wifi connection.

Hello Rava,

Thank you for the hint.

I should have posted also my resolution. Since it is 2 months old, I don’t recall the exact path I took to solve the issue.

However if I’m correct my problem was linked to the fact that the project structure I was using was not compliant with the particle desktop IDE project organisation. And for some reason it only showed up during the last upgrade. I did just reorganized my libraries to comply with these requirement and it did solved the issue*.

Here are more details on the project folders requirements:


*) obviously the error messages were not very helpful to find the root cause, and I did wasted a few hours to figured it out :slight_smile: