Asset Tracker GPS real-time google map

I’m sure they’ll be on the particle store https://store.particle.io eventually. Keep watching there. No idea of an ETA though.

I got mine running the sample app for assettracker - the gps light blinks, but after a few minutes even the “batt” function stops working - has yours been reliable/online?

Yeah, mine has been really stable as long as there is enough power left in the battery.

Does anyone have an explanation for why the GPS light will blink once a second (trying to find a fix) to not blinking at all?

When I don’t use the external antenna it always blinks once a second no matter where I have it. It can be outside in the sun, and it won’t get a fix even after an hour.

When I do use an active antenna+adapter (from Adafruit) it stops blinking within minutes, but it does not blink once every fifteen seconds like I expect it to.

I’ve tried using external power as well and there is no difference in behavior (except the charging LED of course).

When it’s not blinking, I’ve found that it’s got a valid GPS fix. when it’s blinking is when it’s searching. Without the antenna it takes a long time, and depending on the conditions it won’t ever get a fix. With the external antenna it’s been awesome. It could be that with the antenna it doesn’t need to do much to get a reading, so blinking isn’t necessary.

Yeah, it seems to have a valid fix but everything I’ve read says “When the GPS Fix LED is blinking once per second (1Hz) then it is trying to get a fix but does not yet have one. It will blink once per 15 seconds when it actively has a fix, and you can check that from code using the .gpsFix() function.”

So why isn’t it blinking once per 15 seconds?

I’m curious about what generates that LED. My initial assumption of it being tied directly to the GPS chip might be wrong. Or maybe something on the GPS chip is overriding the once every 15 seconds blink. I’ll have to hunt down all the schematics and datasheets to figure out why I don’t get any blink at all.

But, anyways it does report the GPS position every 10 min (using the sample app) and the link on this thread topic seems to work as well.

I get the same result. It flashes red every so often, probably when it’s querying the satellites but that’s it.
Probably a slight difference between the original and this variation.

I’ve been using this. I love it! It is a huge time-saver that saves me the trouble of copying and pasting into Google Maps. A couple of questions:

1] Is there any way I can hardcode in my electron’s identity into the HTML? Perhaps there is some particle command I could run locally (on Linux) with some options that would give me some identity information to programmatically insert into a local copy of the HTML before it is presented to the browser?

2] I can see feature creep coming into play. I think I’d like to see a time/date stamp with each pin. Does the Google Maps API allow you to embed a comment with the pinmarks?

Thanks again. (Also thanks for your help on the Asset Tracker library debugging!)

The red dropmarks for every value are shown on the screen but on a grey rectangular background.

How I get the map to show up behind them?

SOLVED

Suddenly working fine, I guess opening my API-account at Google had some delay.

1 Like

What are the specific batteries you added and antennae you ordered?

I let it sit for an hour-ish outside and it never connected via satellite.

This is the antennae I’m using: https://www.adafruit.com/products/960
You’ll also need the adapter: https://www.adafruit.com/products/851

For the battery, it’s a CR1220. https://www.adafruit.com/products/380

2 Likes

Chrome complains with a pop up.

“This page was unable to display a Google Maps element. Please contact the site administrator. If you are the administrator of this site, please check the JavaScript console or check the following page for troubleshooting: http://g.co/mapsJSApiErrors

My device is up and running and I was able to even see lat/long once.
This command worked once and I was abe to see the battery. It is a cloudy day here in Berkley, CA and The gps is blinking red all night and still red.
Tried the command “particle call electron batt” on terminal and It worked last night and published the battery level. Today I can’t get the command working. This is what I see after plug in the command.

“Function call failed Something went wrong calling this function: TimeoutError: message Describe reached maximum number of retransmissions”
@Hypnopompia @msens

I got the google maps working. :grinning:

Awesome! What did you do to get it working?

@Hypnopompia. I pasted google API inside the curly bracket. Everything started working fine when I removed the curly bracket. BTW I bought this asset tracker starter kit with 3 months data plan. I flashed the initial codes ( asset tracker ) and haven’t altered anything. How much data chew up the data plan when it publish gps data on 10 min interval. It would be also great If I can draw the line path. Since Saturday I have used 0.17 MB on my 1MB limit.

@Hypnopompia, Any thoughts on How to draw a line path on google maps ?

This?
https://developers.google.com/maps/documentation/javascript/examples/polyline-simple

1 Like

do you know where can we get that Solar panel separately ? it looks awesome !

I got the solar panel from voltaic systems.

1 Like

Hm, well the browser app works just fine when i follow your link http://www.havocstudios.com/assettracker/

However when I tried to upload your source code I get this error.

Any idea of what could be wrong?