Assertion failure on BORON

Last night my boron was working fine. This morning I power it on and get a solid white light and quickly (like 20hz) flashing charge led. after about 10 seconds I get the sos 10blink sos indicative of an assertion failure. The devices cycles like this for like 4 more times then it reboots into the white led followed by the sos blink. The whole while the yellow charge led is flashing quickly. Pressing reset and mode and releasing reset while holding mode does not put it into safe mode.

I do use the STARTUP macro to turn on a power-on led as soon as it is powered up.
But this was working fine last night.

// startup as soon as on
void PowerOnLED()
   pinMode(D2, OUTPUT); 
   digitalWrite(D2, LOW);
STARTUP( PowerOnLED() );

void setup() { ...

Same cable
Same supply
Same code
If I use a different module everything is fine.
Any help would be appreciated.

@ParticleD, or @mstanley are you able to assist?

Hi dnk100,

Sorry on the delay to get back to you on this.

As per a broader investigation, I suspect your issue may be related to an identified issue where the Boron’s NCP is not fully initialized. This can lead to assertion failures, among other issues, as the ICCID is read out as empty, causing some panic states when trying to connect.

If you code worked fine before and stopped working, I’d actually think it’s an assertion failure occurring in the device OS instead, and not your user application.

The initialization failure is not all or none. It can be intermittent and just come and go. That’s likely why you saw it working just fine with sudden failure. For now, when this happens, there’s no guaranteed way to get it working. But if you only power cycle by software reset, I don’t know that the re-initialization will ever occur. You’ll want to fully power off the device (removing all power for several seconds) before turning it on again for a chance to it to initialize properly.

You can find more info about the initialization failure in the lower part of Developer Support Update | Boron Pausing and Setup Concerns which discusses this issue.

We are still seeking to get bugfix out for this. The issue has been merged, but a binary of the device OS that deals with this is not out yet.

Thanks. After letting the device “sit” for the night, it appeared to boot up ok, but then started rebooting randomly. I will check out the referenced link.
Buy for now I will consider it “development” fallout. From and EE standpoint I know it was not handled… shall … we… say… delicately. :face_with_raised_eyebrow:

Hi @dnk100, thanks for the info. I would not rule out some software bugs nonetheless. I’d sit tight and jump on our upcoming v0.9.1 release to see if your issue is resolved by this. :slight_smile:

I have a similar issue but was caused from attempting to use a 3rd party SIM. I followed the directions explicitly but can’t seem to get my boron past an assertion error. I’ve tried to flash the latest firmware but am still getting the assertion error. Are you suggesting that v0.9.1 release may fix this?

Hi @stevieb1 - Did you manage to resolve this issue?
I have the same assertion failure after following the 3rd party sim instructions. :tired_face:

No, I have not resolved this issue. Matter of fact, I followed the process as described exactly, has bricked my boron (flashing SOS red).

I have not been able to recover this device and at this point, not interested in bricking #2 device.

I need a Verizon solution.

So I finally managed to get mine back to a working state. It’s not connecting yet, but that may be a sim issue.
I followed the method in this post to get back to listening mode:

I could then flash the bootloader over serial (not even entirely sure if this was necessary).
And then tried the 3rd party sim setup again.

I now have a flashing green device. Can’t claim it yet though until I can get connected!