Argon always returns to listening mode

My argon device is stuck in listening mode (blinking dark blue). I have already followed all steps outlined in this post Stuck in listening mode Argon to no avail. I have tried to work through the app as well as WorkBench and neither has brought me success.

I realized the problem when I plugged the device into my computer and it was blinking dark blue. My app showed that my device was ‘offline,’ and all attempts to connect it to wifi failed, even though other devices in my house connect to my wifi just fine.

I have tried to put it in DFU mode (yellow) and it immediately returns to listening mode.

I tried typing ‘particle serial inspect’ into the terminal and these were the results:

Additionally, i attempted to flash the device locally and this was the error i received:

You mentioned you tried all the steps in the other thread, however can you try this (again)

particle usb setup-done

If the setup-done command doesn’t work, another strategy would be to place the device into Safe Mode before then placing it in Listening Mode, then running the setup-done command.

1 Like

Yes, tried a few times. terminal reads “Done.” but then I continue to have the same issues.

When I try to enter safe mode, the device blinks magenta briefly, and then starts blinking yellow, then turns white, then back to blinking dark blue. I cannot get it to remain in safe mode. This happens when I do it via the buttons on the Argon as well as when I manually enter safe mode via the terminal.

Can you please open a support ticket at with a video documenting your attempt to place the device into Safe Mode?

Hi, try this:

This is regarding to Boron but instruction shows option for Argon as well. Make sure that you are using a good quality USB cable (the best is the Particle OEM). I’m not sure how to “bite” the issue with entering to DFU mode but maybe this (always work for me) will work

This sounds as if you are holding down the SETUP/MODE button too long.
You have to release it as soon you see the first magenta flash.

I am releasing the button as soon as I see magenta. Same thing happens. It’s also failing to enter safe mode when I do it manually through the terminal.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.