2G/3G EtherSim Boron disconnecting - Blinking Cyan

Hi all,

I have two brand new Borons (BRN314) with EtherSIM that are disconnecting/ not connecting to the cloud very often.

Strangely enough, I setup both devices in the same place, time and conditions, and they connected to different carriers. One is running OS 2.2.0 the other 2.3.0. I am using the Cloud debug tool by rickkass. The same behavior occurs with Tinker and a blank app.

Signal strength in both is >60%.

After the activation process, both devices will connect and will end up blinking cyan, sometimes they get online (one for a couple of seconds, the other one for a couple of minutes), both eventually show this error in the log:

0000780074 [comm.protocol] INFO: Checksum has not changed; not sending application DESCRIBE
0000780074 [comm.protocol] INFO: Checksum has not changed; not sending subscriptions
0000781231 [system.nm] INFO: State changed: IP_CONFIGURED → IFACE_UP
0000781232 [net.ppp.client] TRACE: PPP phase → 9
0000781232 [net.ppp.client] TRACE: PPP phase → 6
0000784432 [system] ERROR: sock_send returned -1 118
0000784432 [comm.dtls] ERROR: mbedtls_ssl_write() failed: -0x4e
0000784534 [system] ERROR: sock_send returned -1 118
0000784534 [comm.dtls] ERROR: mbedtls_ssl_read() failed: -0x4e
0000784534 [comm.protocol] ERROR: Event loop error 34
0000784536 [system] WARN: Communication loop error, closing cloud socket
0000784536 [system] INFO: Cloud: disconnecting
0000784538 [system] INFO: Cloud: disconnected
0000785371 [app] INFO: Still trying to connect to the cloud 08:47
…
INFO: Operator Selection (COPS) Read: mode=automatic (0)
0000072640 [app.help] INFO: format=numeric (2)
0000072642 [app.help] INFO: oper=732123 carrier=Movistar country=Colombia
0000072546 [ncp.at] TRACE: < OK
0000072547 [ncp.at] TRACE: > AT+CGREG?
0000072551 [ncp.at] TRACE: < +CGREG: 2,5,“05AA”,“2C992EE”,6,“32”
0000072649 [app.help] INFO: GPRS network (CGREG) Status: registered, roaming (5)
0000072650 [app.help] INFO: Tracking area code: 05AA
0000072651 [app.help] INFO: Cell identifier: 2C992EE
0000072653 [app.help] INFO: Access technology: GSM + HSDPA & USUPA (6)

I suspect a Simcard issue, any help is greatly appreciated.

Just to be sure: You have the LiPo battery connected, correct? The USB port will not supply enough current by itself on 2G/3G devices with the default settings.

2 Likes

Yes the battery is connected on both devices.
I dont think its a power issue, one of them was online for a couple of minutes

I did some more troubleshooting today.
Upgraded the OS to V3.3.0 manually. For some reason it went into safe mode, and the connectivity started failing in that mode as well.
I tried to get online with OS3.3.0 and 1.5.2 and got the same error codes and same behavior with a slightly different format, but same problems

0000147508 [system] ERROR: sock_send returned -1 118
0000147508 [comm.dtls] ERROR: handshake failed -4e
0000147511 [comm.protocol.handshake] ERROR: Handshake failed: 17
0000147512 [system] WARN: Internet test failed: network
0000147514 [system] WARN: Cloud handshake failed, code=-220
0000147764 [system] INFO: Cloud: disconnecting
0000147764 [system] INFO: Cloud: disconnected
0000147847 [ncp.at] TRACE: < +CGEV: NW DEACT “IP”,“100.75.123.94”,1
0000151493 [app] INFO: Still trying to connect to the cloud 01:50

I will try to use one of the old Particle Simcards and see if that works. Wish me luck!

I used one of the old Particle Simcards, those only use one carrier locally (Movistar) and it stayed online on the first try.

Therefore I can conclude the issue is with the EtherSim, something about the agreement with carriers is not working.

I am happy to help Particle get to the bottom of this, I can send logs and do tests here as you instruct me to.

For us it would be great to be able to use the EtherSim, having the flexibility to use different carriers is a big plus, (not to mention I kinda promised this feature to one of my main clients)